Not logged in. · Lost password · Register

Thunder.bird67
Avatar
Member since Jun 2011
79 posts
Subject: Probleme mit gdb unter SuseLinux
Hallo alle zusammen,

Ich bin gerade dabei verschiedene Linux Distributionen auszuprobieren.
Vor ungefaehr einer Woche habe ich die neueste SuseLinux Distribution heruntergeladen. Zurzeit arbeite ich an einem Programm, dass natuerlich auch gedebuggt werden muss. Aber ich erhalte im gdb immer folgende Fehlermeldun : Missing seperate debuginfos, use zypper install glibc-debuginfo-2.15-22.64.i686

Aber wenn ich versuche dieses Fehlende Paket zu installieren, teilt man mir mit, dass dieses Paket nicht existiert.
Hat irgendjemand eine Idee wie ich das beheben kann?

Vielen Dank schonmal im Voraus.
julupu
Member since Oct 2012
81 posts
In Yast oder zypper das "Debug" Repository aktivieren. Hab gerade nachgeschaut, das ist wohl standardmäßig nicht der Fall.

# zypper lr
# zypper mr -e $NummerDesDebugReposAusDerErstenSpalte
# zypper in glibc-debuginfo
This post was edited on 2013-01-12, 21:59 by julupu.
Thunder.bird67
Avatar
Member since Jun 2011
79 posts
Quote by julupu:
In Yast oder zypper das "Debug" Repository aktivieren. Hab gerade nachgeschaut, das ist wohl standardmäßig nicht der Fall.

# zypper lr
# zypper mr -e $NummerDesDebugReposAusDerErstenSpalte
# zypper in glibc-debuginfo

Joa klappt wunderbar, vielen Dank =)
Close Smaller – Larger + Reply to this post:
Verification code: VeriCode Please enter the word from the image into the text field below. (Type the letters only, lower case is okay.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Special characters:
Go to forum
Datenschutz | Kontakt
Powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2011 by Yves Goergen