Not logged in. · Lost password · Register

algocrack
Member since Oct 2015
15 posts
Subject: MMT Installation Guide
This guide is a quick summary I made to help other students quickly install MMT. It worked for me on MAC OS. You can try it on windows too.
Disclaimer: The official installation guide is found here: https://uniformal.github.io/doc/setup/. I merely show the steps that worked for me. Refer to the official guide in case you have trouble installing MMT.

Here is mine. Ten Steps to install MMT: https://github.com/zolekode/mmt/blob/master/README.md

Cheers
Marcel[Inf]
#faui2k15, GTI-Tutor a. D.
Member since Nov 2015
433 posts
+1 algocrack
Awesome that you want to improve MMT's documentation and actually share this!

Feel free to make PRs at https://uniformal.github.io/doc/setup/ (click 'edit' in the footer)! I've just taken the liberty to incorporate some of your suggestions into that very document and to simplify it, most importantly that the IntelliJ version should match the the one compatible with the plugin.

Right, scala-sbt is also needed for development of MMT. (Although IntelliJ prepackages SBT, it works a bit strangely in recent times.) We should create another article on setting up MMT for dev, I guess. Or edit the existing one. Actually, this is a good thing to work on in the next TODO day at the kwarc group, I guess; I'll forward that.


PS: I'm just a student who is involved with MMT due my current M. Sc. project and my previous B. Sc. thesis. So I am not actually affiliated with the LBS course.
Marcel[Inf]
#faui2k15, GTI-Tutor a. D.
Member since Nov 2015
433 posts
I've just had another look at this:
Install Scala-sbt: https://www.scala-sbt.org/
[...]
then search for Scala and then mmt. Install both plugins.
Why exactly did you need Scala-sbt and the Scala plugin? Did IntelliJ prompt you setup any Scala SDK?+

In any case, this is now tracked in https://github.com/UniFormal/MMT/issues/498, and hopefully tackled at the next todo day.
This post was edited on 2019-12-05, 09:26 by Marcel[Inf].
algocrack
Member since Oct 2015
15 posts
Thanks Marcel. That's a very good question :D. Actually I sometimes did program in scala, so sbt + the scala plugin was already installed on my PC. And since I read that MMT uses Scala underneath, I assumed that a fresh installation might require Scala sbt +- the scala plugin. So just to be sure I added it to the installation steps.
I probably should have mentioned that too on the guide.

Cheers.
leonopulos
Member since Jan 2017
6 posts
The
construct
and
show
commands don't seem to be working for me. I simply get a "command not found" error.
I installed via the official installation guide and am using GLF through jupyter notebooks. Any idea on throubleshooting?
Close Smaller – Larger + Reply to this post:
Verification code: VeriCode Please enter the word from the image into the text field below. (Type the letters only, lower case is okay.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Special characters:
Go to forum
Datenschutz | Kontakt
Powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2011 by Yves Goergen